请选择 进入手机版 | 继续访问电脑版

默认
发表评论 4
想开发IM:买成品怕坑?租第3方怕贵?找开源自已撸?尽量别走弯路了... 找站长给点建议
目前Web IM里用得jquery是1.8,jq升级到3.5或最新版本,是否会有问题?
目前客户检测jquery版本过低,有安全问题,如果升级大最新版本或者3.5后,是否会有问题?影响

即时通讯网 - 即时通讯开发者社区! 来源: - 即时通讯开发者社区!

推荐方案
评论 4
别信这种检测了,js本身所有源码都加载到客户端,安全就不是由客户端源码保障的。
不过一定要升级的话,应该也可以,因为也没用到jq的什么奇怪功能,无非就是最常见的DOM操作那些,你可以先比对一下兼容性再决定怎么升级
签名: 不开心,不快乐
引用:JackJiang 发表于 2022-06-17 16:33
别信这种检测了,js本身所有源码都加载到客户端,安全就不是由客户端源码保障的。
不过一定要升级的话,应 ...

我也是这么觉得,不过别人检测出来,要改
引用:qinghezi183 发表于 2022-06-22 11:13
我也是这么觉得,不过别人检测出来,要改

那你比对一下jq的官方版本兼容性列表,然后改下看看,通常这种标准库升级没什么麻烦,只是偷懒就偷懒而已,又不需要它的什么新特性
签名: 不开心,不快乐
打赏楼主 ×
使用微信打赏! 使用支付宝打赏!

返回顶部